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OBJECTIVES 

 
PART I Learn how to project/specify projection of an image in SeaDAS 
 
PART II Learn how to utilize masks and extract data 
 

 
PART I: PROJECTING AN IMAGE  

 
Before you start this section, make sure to download the L2 files, 
AQUA_MODIS.20151215T174001.L2.OC.nc and 
AQUA_MODIS.20151231T210001.L2.OC.nc from canvas or the course website (in the 
L2 directory of Lab2). You will also be using these files for Lab 3 next week. 
 
By projecting an image, you can create evenly gridded maps of data within a specific 
area. Depending on where you are in the world, certain map projections are more or 
less appropriate.  
 
Here’s an unprojected image you will process in this lab. Notice how the gridlines are 
unevenly space and curved: 

 
Now, after we project it, the scene is mapped onto an evenly spaced grid and the 
landmass is recognizable as the east coast of the U.S. (note: we have also added a 
landmask, shown in gray) 
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1. Now it’s your turn to project an image! 
2. Open one of the L2 MODIS oceancolor (unprojected) images that you copied 

from the Lab 2 folder  
a. Display a band and gridlines on it to see what the unprojected image looks 

like. 
b. Go to Raster > Geometric > Reprojection 

i. Under “Reprojection Parameters”, you can: 
1. Select your projection and any other parameters. For now, 

you can leave the default reprojection parameters. 
2. Click run. This may take a few minutes.  
3. When it is finished, close the Reprojection window 

ii. Display a reprojected band and add and gridlines. 
1. You may add a landmask at this point, but this might slow 

you down as the mask loads. 
2. Notice the difference? Is the area more recognizable? 
3. Remember, if you are unsure of where your image is from, 

you can check the “World Map” window in the upper left to 
see where your scene is from. The active window will be 
displayed by the red box.  

3. Now, repeat the reprojection process for the second L2 image. 
4. The “Mosaic” tool allows for more flexible settings when projecting images. There 

are a few different uses for Mosaic: 
a. For example, “reprojecting” will project only within the lat/lon bounds of 

your scene whereas Mosaic allows you to choose the boundaries of your 
projection.  With Mosaic you can project different scenes in exactly the 
same way whereas with Reproject the boundaries will depend on the 
lon/lat bounds of the scenes. 



Lab 2 
 

3 

b. You can also create ‘Mosaic’ images with multiple L2 scenes on a single 
mapped image. 

c. To make a Mosaic: 
i. Click Raster > Geometric > Mosaic 
ii. Under “I/O Parameters”  

1. Click “+” to add both of the L2 files you have been working 
with so far today 

2. Choose a name for the Mosaic output (default is ‘mosaic’) 
3. Change the directory (where your mosaic will be saved) if 

needed 
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d. Next, click “Map Projection Definition” 
i. NOTE: There is a bug in the current version of SeaDAS, and this 

screen will not load correctly. The screen should look like this, but 
because of an issue with the world map graphic, this page will not 
appear. It will instead look like clicking “Map Projection 
Definition” did nothing 

 

 
 

ii. TO WORK AROUND THE ISSUE: Once you click on “Map 
Projection Definition”, hit the ‘tab’ key on your keyboard. This will 
cause ‘Custom CRS’ and a projection dropdown to appear on top of 
the previous menu. It should look like this: 
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iii. Change the projection in the dropdown to any other projection (I 
used ‘Gnomonic’) you should see additional options appear in the 
middle of the menu – specifically lat/lon boundaries for your mosaic 

iv.  
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v. You can now freely change your map projection and modify the 

boundaries of your mosaic using the North, South, East, and West 
boxes 

1. The default projection is “Geographic Lat/Lon (WGS 84)” 
2. You can experiment with the different projections. 

 

 

 
vi. To set the boundaries of your mosaic, it is helpful to overlay 

gridlines over the original images, and figure out the eastern, 
western, northern, and southern bounds from your gridlines 

vii.  If you have any trouble with this step, call over one of the 
instructors! 
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e. Once you are satisfied with your projection and boundaries, click over to 

“Variables & Conditions” 

i. Select  to pick which products (bands) to display 
1. There will be many options, chlor_a is chlorophyll a, and is 

the primary band we want to display today, but you can 
select all to preserve all bands. 

 

 
 

ii. Click “Run” to produce your mosaic 
iii. When it is finished running, close the Mosaic window 
iv. Display the new mosaic image 

1. Try adding a landmask and gridlines! 
 
Before continuing to the next part of the lab save your SeaDAS session as a 
precaution, in case SeaDAS becomes unresponsive. 
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PART II DATA ANALYSIS: MASKS AND DATA EXTRACTION 
 
Now that your image is projected, it’s time to analyze the data! There are different 
approaches to data analysis of satellite images. You can either analyze the entire 
scene, but likely you’ll want to analyze a consistent region of interest (ROI). You can do 
this by creating a “mask”: 
 
MASKS:  
 

1. Now, display the projected L2 image (not the mosaic) of the East Coast of the 
USA  

 
2. You can create a mask to analyze data constrained to a certain region. Any mask 

you create (like the land masks you made previously) are stored in the “Mask 
Manager” (window on the right). Go there now: 

a. Logical Band Maths Expression:  
i. Before you open the Band Maths Expression window, first get an 

idea of where you want to put your mask. 
1. Look at the “Pixel Info” window on the right while you move 

your cursor to get a sense of the lat/lon of your image.  
2. Write down the lat/lon limits you want for the mask you will 

create next.  
3. Remember that West and South are negative. 

ii. Now, open the Logical Band Maths Expression by navigating to the 

Mask Manager and then clicking  where you can use different 
criteria in your math expression.  Make sure to use the logical 
band maths expression button in the mask manager panel (not 
in the top panel). 

iii. You can use any variable listed under Data sources.  For this 
example, let’s constrain by latitude and longitude. In that case, 
these will be your “constants”.  

1. Note: if you use the latitude or longitude BANDS from your 
image, the mask will only extend to the boundary of your 
image. LAT and LON can also be found in the “Constants” 
dropdown, and this will create masks that can extend 
beyond a single image. 

iv. You can create a math expression to constrain your mask. You can 
create the expression using the buttons or by typing. You can 
check whether you’ve typed it accurately by the text at the bottom 
(“OK, no errors”) 
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v. Click “OK” 
vi. Now, your mask should be displayed on your scene (see below) 
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vii. If your mask isn’t displaying where you expected, you likely made a 
mistake in writing the band math expression. If you want to edit the 
expression, select the mask you just made in the mask manager list 

and click the edit icon  
 

viii. Under “Mask Manager”, you can toggle the mask on/off and change 
the color/transparency of the mask 

 
ix. In Mask Manager, when a mask is selected, you can:  

1. Edit the mask criteria   
a. Hint: you must edit in the “editor” window. You cannot 

edit by changing the text description box to the right of 
the color/opacity. That is only the description, not the 
mask criteria! 

2. Double click to change the mask name (this is helpful when 
you start making many masks!) 

3. Change the color and transparency  
 

x. You can also create masks based on value range using the Range 

Mask ( ) 
1. This way of creating a mask is based on your data (and this 

can be based on data from another band that you’re not 
currently displaying!)  

2. For instance, you can create a layer that masks where 
chlor_a is between 0 and 1 

 

 
 

xi. There are pre-made masks that are included with your L2 images.  
1. For example, some of these masks are for pixels that are 

“flagged” for a variety of quality control reasons. 
2. Hover over the different pre-made masks to read the 

descriptions 
3. If you wanted to create a mask that encompassed multiple 

masks for “bad” data so you can exclude it for your analysis, 
it might make sense for you to create a mask that 
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encompasses all these flagged pixels 
4. To do so, highlight the masks you want to include (by 

holding the command key) and click the button to “Create a 
union of selected masks” 

 
 
 

5. This creates a new mask, perhaps called “not_valid” 
6. If you wanted to create the complement mask of “not_valid” 

(aka, VALID data pixels), highlight “not_valid” mask and click 

 
 

 
 

xii. Often times in data analysis, you may want to save your mask to 
use repeatedly.  

1. You can do this for individual masks or a group of masks. 
Highlight the masks you want to include (to select multiple at 
once by holding down the command key) 
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2. Export the mask by pressing the “export” icon (see below), 
name it, and save it to your folder.  

a.  

3. Now, delete that mask just exported from mask manager.   

4. Try reimporting the mask and displaying it on your OC 
image  

 
xiii. Finally, you can create “Geometry” masks. These are slightly 

different from the previous masks because they are vector data (vs. 
raster data). If you want to know more about the difference between 
vector and raster data, you can see the SeaDAS Help Page 

1. You can create a new square, circular, or polygon shape 

 
a. For polygons, click to add a new vector point. When 

you are finished, double click to close the shape 

2. To edit the geometry shapes, use the pointer tool  
a. Select a single geometry by clicking it.  
b. Select one or more geometries by dragging a 

selection rectangle around them. 
c. Double click the shape to enable the vector points 

(white circles) 

 
i. Move the shape: Selected shapes can be 

moved to another location by clicking and 
dragging them with the mouse when it is in 
mouse mode. 

ii. Move a vector point: Click and hold a vector 
point to move a single vector point. 

iii. Add a vector point: Click and hold a vector 
point. Then hold control and move the new 
vector point.  

https://seadas.gsfc.nasa.gov/help/
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iv. Remove vector points: Click and hold the 
vector point you want to remove. Move the 
point on top of another vector point, then hold 
control, then release the key and the mouse.  

v. Scale: Click the shape again so that the 
entire shape is surrounded by the square box 
with white square points. You can click and 
drag the white boxes to scale the shape.  

 
vi. Cut, Copy, Paste: Click to select the shape.  

In the Edit menu, cut or copy. Then 
Edit>paste.  

vii. Delete: Use the command from the Edit 
menu or use the Delete key.  

3. You can save the shape two ways: 
a. One, as a shapefile: 

i. Right-click on ‘geometry’ (or geometry_1, … if 
you made more than one) in the “Vector 
Data” folder of your file in File Manager. 

1. NOTE: NOT Layer Manager 
ii. Select “Geometry as Shapefile” 
iii. Test it on another file before closing the 

image.  (Vector -> Import -> ERSI Shapefile) 
b. Two, as text: 

i. Selecting the geometry shape you want to 
save 

ii. Right clicking the shape and selecting “WKT 
from Geometry” 

iii. Copy (command + C) the text (which includes 
the lat/lon of all the vector points) 

iv. Then, to add the shape file, right click the 
image and click “Geometry from WKT” and 
paste in the text.  

v. The shape should be added. 
vi. If you want to use a mask repeatedly during 

your analysis, you could save this text to use 
in future SeaDAS sessions. 
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STATISTICS + PLOTS: 

2. To analyze your image or data within a mask, you can do some statistics by 

clicking the statistics button ( ) or Analysis > Statistics 
a. First, make sure the band you want to analyze is selected in “File 

Manager” (for example, the “chlor_a” band) 
b. You can select one of your regions of interest (ROI) as a mask or leave it 

blank to analyze the entire image   
c. Click the “Run” to analyze 
d. You can export the data to a spreadsheet by highlighting it and just 

copying and pasting.  
 

3. In addition to statistics, you can visually display your data with a variety of plots 

 
a. You can find these same options under the Analysis menu 
b. First, make sure the band you want to analyze is selected in “File 

Manager” (for example, the “chlor_a” band) 

c. You can create a histogram which tells you about the distribution of 
your data. For something like chlorophyll, a log scale may be most 
appropriate. Once you have selected the scale and axes you’d like, click 
the refresh button to plot the histogram. 

 

d. You can create a scatter plot that shows the relationship between two 
parameters (for instance, two different bands or data vs. latitude). Once 
you have selected the scale and axes you’d like, click the refresh button to 
plot the histogram. 
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e. To save either histogram or scatter plots as a picture (png file), right click 
on the image, then click Save As > PNG  

 
 
 
 
BATHYMETRY: 

4. You can also look at the bathymetry and elevation  

a. Click . Leave the parameters as is, and click “Create Bands and 
Mask.”  When you use this tool for the first time you will be prompted to 
download the bathymetry database first. 

i. You can create topography and elevation bands alongside 
bathymetry by clicking the check boxes under Band Options 
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b. You have created up to three new bands: bathymetry, topography and 
elevation. From File Manager, display the bands you created and use the 
cursor to get a sense of these values. 

c. This also creates the mask “BATHYMETRY” in mask manager 
i. If you wanted to visualize where on your map the bathymetry is less 

than a given depth, open the mask editor for the bathymetry mask. 
Here’s how you would change it for if you wanted to see where on 
your map the bathymetry was shallower than 500m using Band 
Maths.  

 
ii. You could also do the same thing (limiting the bathymetry to 

shallower than 500m) by using the Range Mask ( ). Try it! 
iii. Now the new bathymetry mask indicates that the blue masked area 

has a bottom depth shallower than 500m 
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d. Now, let’s try creating a new mask that only contains chlorophyll where the 
depth is greater than 500m 

i. Select the Chl a mask and the bathymetry mask (by clicking one, 
holding “command” and clicking the other).  

ii. To make a mask that obeys both criteria, select  

 
1. Try using the different options including creating masks that 

are a union, difference or complement of the selected 
masks.  

2. Another way to create this mask is to edit the Band Maths 
Mask expression as: bathymetry > 0 and bathymetry < 500 
and chlor_a > 0 

 
DATA EXTRACTION: 
 

1. To extract data from your satellite image, you can: Right click on the image to 
“Export Mask Pixels” and select a mask. This will generate a text file with data 
from all the bands from all the pixels within your mask ROI. Beware, this can be a 
very big file if you do a large mask! 

2. You can also use the Pin tool and Pin manager to extract data from specific 
coordinates 

 
 
 
 

At this point, SAVE YOUR SESSION! 
You may want to revisit this session 

in LAB 3 
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Getting Credit for this Lab: 
 
To get credit for this lab we want you to create a histogram of Chlorophyll a data from 
inside the mask you just created (Bathymetry > 500m). Save the histogram as a PNG 
file and email it to Prof. Arrigo (arrigo@stanford.edu).  
 
If you have any questions, do not hesitate to ask! 

mailto:arrigo@stanford.edu

