Lab 2


OBJECTIVES

PART I Get acquainted with the different kinds of satellite data: 
· Where can I find them? 
· How do I access them? 
· What does this name mean? 
· Understand the differences in data levels.
· Processing Level 1 -> Level 2 data

PART II Learn how to project/specify projection of an image in SeaDAS

PART III Learn how to utilize masks and extract data


PART I: ORDERING, DOWNLOADING, AND PROCESSING DATA

The first part of the lab shows you where you can access data for your future projects. Explore the sites and familiarize yourself with where and how you can order data. 

The goal of this lab is to learn how to order different data levels. Remember from class that data is available at different levels. 
· Level 0 is unprocessed instrument data
· Level 1A is unprocessed instrument data with ancillary information
· Level 1B is data processed to sensor units (e.g., brightness temperature)
· Level 2 is derived geophysical variables (e.g., chlorophyll concentration)
· Level 3 is geophysical variables that are mapped on a grid. 
· * You will mainly be using Level 2 and 3 data in this class
· More information can be read here: https://oceancolor.gsfc.nasa.gov/products/
· https://science.nasa.gov/earth-science/earth-science-data/data-processing-levels-for-eosdis-data-products 
[image: ][image: ]


Part 1. Downloading data

Accessing Ocean Color data
 
SeaWiFS data can be ordered from the OceanColor website at NASA's Goddard Space Flight Center: https://oceancolor.gsfc.nasa.gov/ . Go to this website so you can see how to download data in the future. From the “DATA” tab on the top, under “Find Data” select "Level 1&2 Browser" or "Level 3 Browser" thumbnails. 

Level 1 and 2 data:
· In the Level 1 and 2 data browser, you can select your satellite sensor in the upper left box. The default sensor is always MODIS-Aqua. If you wish to change the sensor (for instance to SeaWIFS GAC data), deselect MODIS-Aqua and select the new product. Click “Reconfigure page” beneath the map. 
· You can specify a day, week, or month by clicking on the calendar below. Images will be generated for any dates displayed in green. To select data for just one day, click on the date. To select data for an 8 day period, click on the symbol below the date (e.g., ‘xxx’). The date or range of dates selected appear in green. Try picking a week (8 day period)!
· To limit your search to a region, you can either select pre-made regions or define your latitude/longitude limits (on the upper right). When you are happy with your dates and region, click “Find swaths”. Try picking a region!
· Tip: if you expect a lot of scenes increase the number to say 100 in the ‘Display results xx at the time’ field below the map or at the top of the results page.

For example, here my search results will be for MODIS data for the 8-day period beginning Friday May 17, 2013 focusing on “Australia”:

[image: Macintosh HD:Users:kate:Desktop:Screen Shot 2016-01-12 at 2.10.27 PM.png]

The screen grab of my search results confirm this:

[image: Macintosh HD:Users:kate:Desktop:Screen Shot 2016-01-12 at 2.10.55 PM.png]

Filename Convention: Click on the file name of an individual scene. You can tell a lot from the file name. For level 2 files, naming conventions follow this pattern: sensor_satellite_ttt.yyyymmddThhmmss.L2.ppp.nc, where:
· Sensor_satellite = SEASTAR_SEAWIFS, AQUA_MODIS, etc.
· ttt = optional data type identifier (GAC, LAC etc.)
· yyyymmddThhmmss = year, month, day, ‘T’, hour, minute, second of first scan line
· L2 = level 2 image
· ppp = product identifier (OC for ocean color, SST for sea surface temperature or IOP for inherent optical properties)
· more information :  https://oceancolor.gsfc.nasa.gov/products/#product_suite

For instance, we can tell the following about the file: 
SEASTAR_SEAWIFS_GAC.20021204T035806.L2.OC.nc 
· SEAWiFS product
· December 14, 2002 
·  GMT Time 03:58:06 
· Level 2
· global area coverage
· ocean color image scene
· nc is the file format, netCDF4. 

Scan the data that are available. Don’t forget that there may be more scenes than are shown. You can either change to display more images at once (at the top) or go page by page by selecting the page number at the bottom. 

[image: Macintosh HD:Users:kate:Desktop:Screen Shot 2015-12-15 at 1.53.08 PM.png][image: Macintosh HD:Users:kate:Desktop:Screen Shot 2015-12-15 at 1.53.11 PM.png]

TIP: Do not use the ‘back’ button of your browser to go back a page, but use the arrow symbols (top-left, see below) to navigate back and forth.  Use the HELP button on the right to see what the other symbols mean.
[image: Macintosh HD:Users:gertvd:Desktop:Screen Shot 2016-01-05 at 11.50.15 AM.png]

Go back to the previous page where there are multiple thumbnails. You can order all files in your search at once by clicking the blue “ORDER DATA” button (which can be a lot, and will take a lot of disk space and a long time to download and process) or you can select only the ones you need (for example those that have a lot of valid pixels) by clicking on the 4 asterisks above the thumbnail.  Now when you click on ORDER DATA only the selected ones will be in your order.
· Login if needed
· Do or do not extract the order
· Click on desired data products if needed
· Click review order
· Click submit and confirm the order via email 
· They don’t always stage the order.  You can also get a list with the filenames.  When you use the extract function or when you select specific product (subset) instead of the standard L2-products you will have to wait for it to be staged.  So if you want your data right away use ‘Do not extract’ and don’t use a subset of the standard L2 products.  
· You should receive an email when the files are ready, or you can check the status at: https://oceandata.sci.gsfc.nasa.gov/odps/orders/. Feel free to continue on to other parts of the lab while waiting.
· If you are downloading a single file, you will get a URL that look something like this: https://oceandata.sci.gsfc.nasa.gov/ob/getfile/AQUA_MODIS.20120723T115501.L2.OC.nc
· If you are downloading several files, you will get a link to an http_manifest.txt that, when downloaded and opened, contains URL(s), perhaps to a zipped tar file like this:
https://oceandata.sci.gsfc.nasa.gov/cgi/getfile/requested_files_1.tar?h=ocdist308&p=/data1/c080b1cb25d6346a/requested_files
· There are several ways to download the files, see: https://oceancolor.gsfc.nasa.gov/data/download_methods/, and select the “Download Methods” tab.  First you have to create a .netrc file, which you should’ve done at the end of Lab 1. 
· One easy way to download is to copy and paste the URLs one by one into your browser address bar. It should automatically download once you are logged into Earthdata.
· You can use the python script obdaac_download, which is preinstalled with SeaDAS. In your terminal, enter
obdaac_download -v “URL”
Replace URL with either the single file URL.  
To download all files listed as URLs in a textfile, like http_manifest.txt:
obdaac_download -v --filelist http_manifest.txt
To download your order using the link to the http_manifest.txt file provided in your order confirmation (all 1 line):
obdaac_download -v --http_manifest “https://oceandata.sci.gsfc.nasa.gov/cgi/getfile/requested_files_1.tar?h=ocdist308&p=/data1/c080b1cb25d6346a/requested_files”
Note the double quotes.
· You can use curl in your terminal for single files:
curl -OLn -b ~/.urs_cookies -c ~/.urs_cookies “URL”
· You can unzip a tar file by double clicking on a Mac. With Windows right click on the file and choose the Extract option.

Level 3 data:
Go back to the OceanColor website and under “DATA” this time navigate to “Level 3 Browser”. Select your desired product, timescale, and resolution. To download data, click on the thumbnail of the image you want, and select “SMI” (standard mapped image) or “Bin” (binned). For this class, mapped SMI files will be easiest to work with.  If you just want the image (no data) select “Images”.  

Getting SST data:

There are multiple SST products you can use. Take a look at the sites below to get familiar with sites from when you can order SST data. (You don’t need to order anything now, this is a reference for your future projects)

AVHRR Data:
http://www.nodc.noaa.gov/SatelliteData/pathfinder4km/

GHRSST Level 4 MUR (multiscale ultrahigh resolution (0.01 degree), multi sensor)
https://podaac.jpl.nasa.gov/dataset/MUR-JPL-L4-GLOB-v4.1

Optimally Interpolated SST data (OISST, 0.25 degree resolution):
http://www.esrl.noaa.gov/psd/data/gridded/data.noaa.oisst.v2.highres.html 

MODIS SST data 
· From the OceanColor website, you can download SST images the same was as ocean color images above. You simply specify the MODIS SST product:
· For Level 1 and 2, specify on top bar: [image: Macintosh HD:Users:kate:Desktop:Screen Shot 2015-12-15 at 2.09.22 PM.png]
· For Level 3, simply choose a SST product from the menu

Accessing other data:

The new SeaDAS is an ‘add-on’ to SNAP (http://step.esa.int/main/toolboxes/snap/ , formerly known as BEAM http://www.brockmann-consult.de/cms/web/beam/ ), an open-source toolbox for viewing, analyzing and processing remote sensing data, made available by the European Space Agency. SeaDAS can easily read most files in netCDF or HDF format.

Here are some examples of L3 data products available and where you can find them:

SSM/I Sea Ice Concentration: 
https://nsidc.org/data/docs/noaa/g02202_ice_conc_cdr/
ftp://sidads.colorado.edu/pub/DATASETS/NOAA/G02202_v2/

Aquarius Wind Speed
https://podaac.jpl.nasa.gov/dataset/AQUARIUS_L3_WIND_SPEED_SMIA_7DAY_V4

AVISO Level 4 Absolute Dynamic Topography
https://podaac.jpl.nasa.gov/dataset/AVISO_L4_DYN_TOPO_1DEG_1MO?ids=Measurement:ProcessingLevel:DataFormat&values=Sea%20Surface%20Topography:*4*:NETCDF

Sea Surface Height from Copernicus
http://marine.copernicus.eu/services-portfolio/access-to-products/?option=com_csw&view=details&product_id=SEALEVEL_GLO_PHY_L4_REP_OBSERVATIONS_008_047

Aquarius Sea Surface Salinity
http://aquarius.umaine.edu/cgi/data.htm

Ocean Surface Current Analysis (OSCAR)
https://podaac.jpl.nasa.gov/dataset/OSCAR_L4_OC_third-deg 

National Centers for Environmental Prediction (NCEP) Surface Data 
http://www.esrl.noaa.gov/psd/data/gridded/data.ncep.reanalysis2.surface.html

From the BEAM website (http://www.brockmann-consult.de/cms/web/beam/): 
You can find many different satellite products easily at PODAAC (Physical Oceanography Distributed Active Archive Center). You can filter for data product, collection, level, and/or datatype (remember .nc, .netcdf, or .hdf tend to work best with this version of SeaDAS) 

Supported Instruments
This following table lists the data product formats which are supported by BEAM using the reader modules provided in the standard installation. Information about the access to these products is given at http://www.brockmann-consult.de/beam/doc/help/general/BeamDataSources.html
	Instrument
	Platform
	Formats

	MERIS L1b/L2
	Envisat
	Envisat N1

	MERIS L3
	Envisat
	NetCDF

	AATSR L1b/L2
	Envisat
	Envisat N1

	ASAR
	Envisat
	Envisat N1

	ATSR L1b/L2
	ERS
	Envisat N1, ERS

	SAR
	ERS
	Envisat N1

	OLCI1)
	Sentinel-3
	NetCDF/SAFE

	SLSTR1)
	Sentinel-3
	NetCDF/SAFE

	MSI1)
	Sentinel-2
	JPEG2000/SAFE

	CHRIS L1
	Proba
	HDF4

	AVNIR-2 L1/L2
	ALOS
	CEOS

	PRISM L1/L2
	ALOS
	CEOS

	MODIS L2
	Aqua, Terra
	HDF4

	AVHRR/3 L1b
	NOAA-KLM
	NOAA, METOP

	MSS
	Landsat 1-5
	GeoTIFF

	TM
	Landsat 4
	GeoTIFF

	TM
	Landsat 5
	GeoTIFF, FAST

	ETM+
	Landsat 7
	GeoTIFF

	OLI, TIRS
	Landsat 8
	GeoTIFF

	SPOT VEGETATION
	SPOT
	HDF




Part 2. Processing data:

Processing L1  L2 
This step may not work on a Windows computer.

Level 1 files contain the radiance counts at each channel received by the ocean color sensor. To translate these to normalized water leaving radiance (nLw), remote sensing reflectance (RRS), chlorophyll, etc. we have to process the files to Level 2 by applying atmospheric corrections and bio-optical algorithms. The SeaDAS function to do this is called: 'l2gen'. See also Overview of MODIS Aqua Data Processing and Distribution on the OceanColor website. There is a similar page for SeaWiFS.

1. Find the L1A images for today’s tutorials in the class directory (ESS141/Lab2/L1A/)
· S2007269172639.L1A_GAC (SeaWiFS)
· A2009165075500.L1A_LAC (MODIS Aqua)
· Note that all the L1 files are named such that the first letter refers to the sensor (S=SeaWiFS, A=MODIS Aqua) but that the rest of the files (L1B, GEO, L2, etc.) start with sensor_satellite (e.g., SEASTAR_SEAWIFS, AQUA_MODIS). We don’t know why this is—take it up with NASA.
2. Copy both files into your own personal folder.  Make sure the folder name does not have any spaces in it (Linux doesn’t like spaces!)  Use underscores instead.
3. Start SeaDAS 
4. If you haven’t already created a .netrc file, go back to Lab 1 and do this!


Steps for SeaWiFS L1  L2
1. Open the SeaWiFS L1A file from your personal folder
a. Look at what bands are stored in the images 
2. Generate a level2 image from the level 1 image by opening “l2gen” under SeaDAS-Toolbox > SeaDAS Processors
3. Use the preset options for OCSSW location
[image: ]
4. Under the “Main” tab
a. Specify your L1A infile (ifile) 
b. The output file (ofile) name will automatically be created in the same folder location using the same naming convention. You can modify this if you wish. *If it isn’t populating automatically and the “Run” button is grayed out, it can help to “Cancel” the window and open l2gen again.
c. Click “Get Ancillary > Get Ancillary” to collect ancillary data for the date/time of your scene, such as meteorological and ozone data. You should see a popup window “GetAnc” while it processes the request.  If you don’t ‘Get Ancillary’ it will use climatological data.  If this step doesn’t work than there is probably a problem with your .netrc file…
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5. Under “Products” you can select which products you want to be generated in the L2 file. 
a. Click the triangle beside the categories (ex. Radiances/Reflectances) to see the full list of products
b. How many of these products do you recognize? Once a product is selected, you can hover over each selection to get a description 
c. You can click or unclick 
d. The products to be processed will be displayed in the “selected products” box
[image: ]
6. Click “Run” and the new L2 file (with associated product bands) will show up in file manager!
7. Check your output
a. What bands are created? 
b. Can you recognize which part of the world this scene is from?  Hint: Add a landmask or grid, or click on the ‘World Map’ tab.


Steps for MODIS L1  L2 

Processing L1A MODIS-Aqua images to L2 requires two extra steps. 

1. Open the L1A MODIS-Aqua image (from your personal folder)
2. Unlike SeaWiFS, geolocation data (latitude/longitude information) are not included in the L1A file and must be generated first. 
a. SeaDAS-Toolbox > SeaDAS Processors > MODIS > modis_GEO
i. Select L1A MODIS/Aqua input file
ii. The GEO file is automatically generated
iii. Run!
[image: ]
If an exception is raised when you do this step, you can download the GEO file from Canvas.


3. Now, you can create the L1B file which will contain calibrated radiances
a. SeaDAS-Toolbox > SeaDAS Processors > MODIS > modis_L1B
b. In the ifile, load the MODIS L1A file
c. The GEO file field should be populated automatically. 
d. Select “Open in SeaDAS” so that the L1B file will be added to the File Manager list 
e. Run!
f. Check the contents of the L1B file you created.
i. SeaDAS creates three L1B files of different resolutions: standard (unlabelled, local area coverage or 1 kilometer), HKM (half kilometer), and QKM (quarter kilometer).  Where in the world was this scene taken from?  Can you spot the sea ice in the QKM file?
ii. You will use the standard 1 km L1B LAC file only in the next step.
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4. Finally, we can use the L1B and GEO file to create a L2 file
a. SeaDAS-Toolbox > SeaDAS Processors > l2gen
b. Select the correct L1B_LAC input file (the GEO file should be added automatically)
c. “Get Ancillary” data and choose your L2 preferences if applicable (like with the SeaWiFS example above). 
d. Check “Open in SeaDAS” to load the L2 band 
e. Run (this may take a few minutes)
f. Check out the result.  Display the chlor_a band for example, zoom in on the phytoplankton bloom, add a landmask/coastline, grid, etc.

[image: ]





PART II: PROJECTING AN IMAGE 

Before you start this section, make sure to download the L2 files, AQUA_MODIS.20151215T174001.L2.OC.nc and AQUA_MODIS.20151231T210001.L2.OC.nc from canvas or the course website (in the L2 directory of Lab2). You will also be using these files for Lab 3 next week.

Also, in order to free up some memory, remove all the files loaded in File Manager (right click on the name and select “Close”, or use File -> Close) or quit and reopen SeaDAS.

By projecting an image, you can create evenly gridded maps of data within a specific area. Depending on where you are in the world, certain map projections are more or less appropriate. 

Here’s an unprojected image you will process in this lab. Notice how the gridlines are unevenly space and curved:
[image: Map

Description automatically generated]

Now, after we project it, the scene is mapped onto an evenly spaced grid and the landmass is recognizable as the east coast of the U.S. 

[image: A picture containing map

Description automatically generated]

1. Now it’s your turn to project an image!
2. Open one of the L2 MODIS oceancolor (unprojected) images that you copied from the Lab 2 folder (don’t use the L2 MODIS file you generated in the previous section).
a. Display a band and put a land mask and gridlines on it to see what the unprojected image looks like.
b. Go to Raster > Geometric > Reprojection
i. Under “Reprojection Parameters”, you can:
1. Select your projection and any other parameters. For now, you can leave the default reprojection parameters.
2. Click run. This may take a few minutes. 
3. When it is finished, close the Reprojection window
ii. Display a reprojected band and add a landmask and gridlines.
1. If your landmask looks funny, redo the land mask
2. Notice the difference? Is the area more recognizable?
3. Remember, if you are unsure of where your image is from, you can check the “World Map” window in the upper left to see where your scene is from. The active window will be displayed by the red box. 
3. Now, repeat the reprojection process for the second L2 image.
4. If you want to see your projected image on a global map, click [image: Macintosh HD:Users:kate:Desktop:Screen Shot 2015-12-16 at 7.40.34 PM.png]on the top menu.

5. The “Mosaic” tool allows for more flexible settings when projecting images. There are a few different uses for Mosaic:
a. For example, “reprojecting” will project only within the lat/lon bounds of your scene whereas Mosaic allows you to choose the boundaries of your projection.  With Mosaic you can project different scenes in exactly the same way whereas with Reproject it will depend on the lon/lat bounds of the scenes.
b. You can also create ‘Mosaic’ images with multiple L2 scenes on a single mapped image.
c. To make a Mosaic:
i. Click Raster > Geometric > Mosaicking
ii. Under “I/O Parameters” 
1. Click “+” to add both of the original L2 files 
2. Choose a name for the Mosaic output (default is ‘mosaic’), change the directory if needed.


[image: Graphical user interface, text, application, email
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iii. Under “Map Projection Definition”
1. Select your Projection 
a. The default projection is “Geographic Lat/Lon (WGS 84)”. You can experiment with the different projections.
2. Change your Mosaic Bounds by entering coordinates OR dragging the edges of the red box 
[image: Graphical user interface, application

Description automatically generated]


iv. Under “Variables & Conditions” 
1. Select [image: Macintosh HD:Users:kate:Desktop:Screen Shot 2016-01-12 at 6.32.38 PM.png] to pick which products to display

[image: Graphical user interface, application

Description automatically generated]
v. Run!
vi. When it is finished running, close the Mosaic window
vii. Display the new mosaic image
1. Try adding a landmask and gridlines! Or trying to display it on the global background (like before) and admire your work
viii. Before continuing to the next part of the lab save your SeaDAS session as a precaution, in case SeaDAS becomes unresponsive.










PART III DATA ANALYSIS: MASKS AND DATA EXTRACTION

Now that your image is projected, it’s time to analyze the data! There are different approaches to data analysis of satellite images. You can either analyze the entire scene, but likely you’ll want to analyze a consistent region of interest (ROI). You can do this by creating a “mask”:

MASKS: 

1. Now, display the projected L2 image (not the mosaic) of the East Coast of the USA 

2. You can create a mask to analyze data constrained to a certain region. Any mask you create (like the land masks you made previously) are stored in the “Mask Manager” (window on the right). Go there now:
i. Logical Band Maths Expression: [image: ]
1. Before you open the Band Maths Expression window, first get an idea of where you want to put your mask.
a. Look at the “Pixel Info” window on the right while you move your cursor to get a sense of the lat/lon of your image. 
b. Write down the lat/lon limits you want for the mask you will create next. 
c. Remember that West and South are negative.
2. Now, open the Logical Band Maths Expression by navigating to the Mask Manager and then clicking [image: Macintosh HD:Users:kate:Desktop:Screen Shot 2015-12-14 at 10.15.27 PM.png] where you can use different criteria in your math expression.  Make sure to use the logical band maths expression button in the mask manager panel (not in the top panel).
3. You can use any variable listed under Data sources.  For this example, let’s constrain by latitude and longitude. In that case, these will be your “constants”.  
4. You can create a math expression to constrain your mask. You can create the expression using the buttons or by typing. You can check whether you’ve typed it accurately by the text at the bottom (“OK, no errors”)


[image: Graphical user interface

Description automatically generated]
1. Click “OK”

2. Now, your mask should be displayed on your scene (see below)
[image: Map

Description automatically generated]
3. If your mask isn’t displaying where you expected, you likely made a mistake in writing the band math expression. If you want to edit the expression, select the mask you just made in the mask manager list and click the edit icon [image: Macintosh HD:Users:kate:Desktop:Screen Shot 2015-12-16 at 8.06.05 PM.png]

4. Under “Mask Manager”, you can toggle the mask on/off and change the color/transparency of the mask


ii. In Mask Manager, when a mask is selected, you can  
1. Edit the mask criteria  [image: ]
a. Hint: you must edit in the “editor” window. You cannot edit by changing the text description box to the right of the color/opacity. That is only the description, not the mask criteria!
2. Double click to change the mask name (this is helpful when you start making many masks!)
3. Change the color and transparency 

iii. You can also create masks based on value range using the Range Mask ([image: Macintosh HD:Users:kate:Desktop:Screen Shot 2015-12-14 at 10.15.23 PM.png])
1. This way of creating a mask is based on your data (and this can be based on data from another band that you’re not currently displaying!) 
2. For instance, you can create a layer that masks where chlor_a is between 0 and 1

[image: Graphical user interface, text, application, chat or text message

Description automatically generated]

iv. There are pre-made masks that are included with your L2 images. 
1. For example, some of these masks are for pixels that are “flagged” for a variety of quality control reasons.
2. Hover over the different pre-made masks to read the descriptions
3. If you wanted to create a mask that encompassed multiple masks for “bad” data so you can exclude it for your analysis, it might make sense for you to create a mask that encompasses all these flagged pixels
4. To do so, highlight the masks you want to include (by holding the command key) and click the button to “Create a union of selected masks”
[image: Graphical user interface, application, Word

Description automatically generated]


5. This creates a new mask, perhaps called “not_valid_ocean”
6. If you wanted to create the complement mask of “not_valid_ocean” (aka, VALID ocean data pixels), highlight “not_valid_ocean” mask and click [image: Macintosh HD:Users:kate:Desktop:Screen Shot 2015-12-16 at 1.21.01 PM.png]
[image: Graphical user interface, application

Description automatically generated]

v. Often times in data analysis, you may want to save your mask to use repeatedly. 
1. You can do this for individual masks or a group of masks. Highlight the masks you want to include (to select multiple at once by holding down the command key)
2. Export the mask by pressing the “export” icon (see below), name it, and save it to your folder. 
a. [image: Graphical user interface, text, application, chat or text message

Description automatically generated]
3. Now, delete that mask just exported from mask manager.[image: Macintosh HD:Users:kate:Desktop:Screen Shot 2016-01-12 at 6.59.11 PM.png] 
4. Try reimporting [image: Macintosh HD:Users:kate:Desktop:Screen Shot 2016-01-12 at 6.59.18 PM.png]the mask and displaying it on your OC image 

vi. Finally, you can create “Geometry” masks. These are slightly different from the previous masks because they are vector data (vs. raster data). If you want to know more about the difference between vector and raster data, you can see the SeaDAS7 Help Page
1. You can create a new square, circular, or polygon shape [image: Macintosh HD:Users:kate:Desktop:Screen Shot 2016-01-12 at 7.02.36 PM.png]
a. For polygons, click to add a new vector point. When you are finished, double click to close the shape
2. To edit the geometry shapes, use the pointer tool [image: Macintosh HD:Users:kate:Desktop:Screen Shot 2016-01-12 at 7.05.05 PM.png]
a. Select a single geometry by clicking it. 
b. Select one or more geometries by dragging a selection rectangle around them.
c. Double click the shape to enable the vector points (white circles)
i. [image: Macintosh HD:Users:kate:Desktop:Screen Shot 2016-01-12 at 7.07.06 PM.png]
ii. Move the shape: Selected shapes can be moved to another location by clicking and dragging them with the mouse when it is in mouse mode.
iii. Move a vector point: Click and hold a vector point to move a single vector point.
iv. Add a vector point: Click and hold a vector point. Then hold control and move the new vector point. 
v. Remove vector points: Click and hold the vector point you want to remove. Move the point on top of another vector point, then hold control, then release the key and the mouse. 
vi. Scale: Click the shape again so that the entire shape is surrounded by the square box with white square points. You can click and drag the white boxes to scale the shape. 
[image: Macintosh HD:Users:kate:Desktop:Screen Shot 2016-01-12 at 7.09.28 PM.png]
vii. Cut, Copy, Paste: Click to select the shape.  In the Edit menu, cut or copy. Then Edit>paste. 
viii. Delete: Use the command from the Edit menu or use the Delete key. 
3. You can save the shape two ways:
a. One, as a shapefile:
i. Right-click on ‘geometry’ (or geometry_1, … if you made more than one) in the Vectors folder of your file in File Manager.  
ii. Select “Geometry as Shapefile”
iii. Test it on another file before closing the image.  (Vector -> Import -> ERSI Shapefile)
b. Two, as text:
i. Selecting the geometry shape you want to save
ii. Right clicking the shape and selecting “WKT from Geometry”
iii. Copy (command + C) the text (which includes the lat/lon of all the vector points)
iv. Then, to add the shape file, right click the image and click “Geometry from WKT” and paste in the text. 
v. The shape should be added.
vi. If you want to use a mask repeatedly during your analysis, you could save this text to use in future SeaDAS sessions.


STATISTICS + PLOTS:
2. To analyze your image or data within a mask, you can do some statistics by clicking the statistics button ([image: Macintosh HD:Users:kate:Desktop:Screen Shot 2015-12-15 at 12.08.44 PM.png]) or Analysis > Statistics
a. First, make sure the band you want to analyze is selected in “File Manager” (for example, the “chlor_a” band)
b. You can select one of your regions of interest (ROI) as a mask or leave it blank to analyze the entire image  
c. Click the “Run” to analyze
d. You can export the data to a spreadsheet by highlighting it and just copying and pasting. 

3. In addition to statistics, you can visually display your data with a variety of plots [image: Macintosh HD:Users:kate:Desktop:Screen Shot 2015-12-16 at 2.50.42 PM.png]
a. You can find these same options under the Analysis menu
b. First, make sure the band you want to analyze is selected in “File Manager” (for example, the “chlor_a” band)
c. [image: Macintosh HD:Users:kate:Desktop:Screen Shot 2015-12-16 at 2.51.13 PM.png]You can create a histogram which tells you about the distribution of your data. For something like chlorophyll, a log scale may be most appropriate. Once you have selected the scale and axes you’d like, click the refresh button to plot the histogram.
[image: Macintosh HD:Users:kate:Desktop:Screen Shot 2015-12-16 at 2.49.56 PM.png]
d. [image: Macintosh HD:Users:kate:Desktop:Screen Shot 2015-12-16 at 4.52.44 PM.png]You can create a scatter plot that shows the relationship between two parameters (for instance, two different bands or data vs. latitude). Once you have selected the scale and axes you’d like, click the refresh button to plot the histogram.

[image: Macintosh HD:Users:kate:Desktop:Screen Shot 2015-12-16 at 4.51.49 PM.png]


e. To save either histogram or scatter plots as a picture (png file), right click on the image and Save As 




BATHYMETRY:
4. You can also look at the bathymetry and elevation 
a. Click [image: ]. Leave the parameters as is, and click “Create Bands and Mask.”  When you use this tool for the first time you will be prompted to download the bathymetry database first.
[image: Macintosh HD:Users:kate:Desktop:Screen Shot 2015-12-16 at 1.35.53 PM.png]
b. This has created three new bands: topography, bathymetry, and elevation. From File Manager, display these bands and use the cursor to get a sense of these values.
c. This also creates the mask “BATHYMETRY” in mask manager
i. If you wanted to visualize where on your map the bathymetry is less than a given depth, open the mask editor for the bathymetry mask. Here’s how you would change it for if you wanted to see where on your map the bathymetry was shallower than 500m using Band Maths. 
[image: Macintosh HD:Users:kate:Desktop:Screen Shot 2015-12-16 at 1.38.16 PM.png]
ii. You could also do the same thing (limiting the bathymetry to shallower than 500m) by using the Range Mask ([image: Macintosh HD:Users:kate:Desktop:Screen Shot 2015-12-14 at 10.15.23 PM.png]). Try it!
iii. Now the new bathymetry mask indicates that the blue masked area has a bottom depth shallower than 500m
[image: A picture containing diagram

Description automatically generated]
d. Now, let’s try creating a new mask that only contains chlorophyll where the depth is greater than 500m
i. Select the Chl a mask and the bathymetry mask (by clicking one, holding “command” and clicking the other). 
ii. To make a mask that obeys both criteria, select [image: Macintosh HD:Users:kate:Desktop:Screen Shot 2016-02-03 at 12.16.15 PM.png]
[image: Graphical user interface, text, application

Description automatically generated]
1. Try using the different options including creating masks that are a union, difference or complement of the selected masks. 
2. Another way to create this mask is to edit the Band Maths Mask expression as: bathymetry > 0 and bathymetry < 500 and chlor_a > 0


DATA EXTRACTION:

1. To extract data from your satellite image, you can: Right click on the image to “Export Mask Pixels” and select a mask. This will generate a text file with data from all the bands from all the pixels within your mask ROI. Beware, this can be a very big file if you do a large mask!

2. You can also use File > Export > Other > Mask Pixels to get data values at specified coordinates.







SAVE SESSION! You may want to revisit this session in LAB 3
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