
Lab Notes 1: Getting to know SeaDAS (using SST images) 
 
In this lab, we are working with AVHRR SST data to get familiar with SeaDAS. 
The data you will work with was downloaded from: 
https://www.ncei.noaa.gov/products/optimum-interpolation-sst 
 
 
SeaDAS: 
 
During this course we will use SeaDAS 10 (SeaWiFS Data Analysis System, 
version 10). Although SeaDAS was specifically developed by the Oceancolor 
Group at NASA for analyzing data from the first ocean color sensor, CZCS, back 
in 1994. The software now supports analysis of all US and international ocean 
color satellite data products as well as other sensors.   
 
SeaDAS has many features and can be overwhelming at first! Luckily, there is a 
detailed help section as well as video tutorials available on the SeaDAS website.  
It can be downloaded for free, so you can install it on your own laptop as well. 
 
Load SST data into SeaDAS: 
 
In this lab we use OISST (Optimally Interpolated Sea Surface Temperature) 
satellite data using some basic SeaDAS functions. 
 

1. Go to the course website or Canvas page. Go to Files > Labs > Lab1 and 
download the two .nc files.by clicking on the “Lab 1” link and then the .nc 
files. 

a. See the SST files? Notice the file names. Typically, file naming 
conventions give an indication of the type of data and date  

i. For example, ‘oisst-avhrr-v02r01.20150701.nc’ 
1. “oisst-avhrr-v02r01” refers to the product and version 

number 
2. 20150701 refers to July 1, 2015 
3. When is the second file from? 

b. Download BOTH FILES into your own computer.  It is advised to 
make a dedicated Lab1 directory in your Documents folder and 
place these files in it. DO NOT USE SPACES in this directory 
title or in any file titles – SeaDAS hates spaces. 

 
2. Start SeaDAS by clicking the SeaDAS desktop shortcut (Windows/Mac) or 

by opening a Terminal window and typing “seadas” (Mac only). Open one 
of the SST files by selecting File > Open File 

a. Make sure you are opening the files from YOUR directory you 
created above. 

b. If prompted, open as Generic NetCDF Data Product 
 

https://www.ncei.noaa.gov/products/optimum-interpolation-sst
https://www.earthdata.nasa.gov/data/tools/seadas/installers-source-code
https://oceancolor.gsfc.nasa.gov/data/czcs/
http://seadas.gsfc.nasa.gov/help/
https://seadas.gsfc.nasa.gov/tutorials/


3. Now, in “File Manager” you will see your file displayed. Click on the 
sideways arrow to reveal the subfiles. 

a. “Bands” (or products) refer to the raster data. In this case, sea 
surface temperature 

b. “Metadata” describes contents of the file, variable names, 
dimension, processing etc.  

c. In order to display the SST image, double click the SST band in the 
Bands subfolder. 

i. If the band does not appear, try double-clicking on the icon 
next to the name 

 

 
 
 

d. Under the “Pixel Info” window on the right sidebar, you can see 
data values (SST) and location (lat, lon) at each pixel as you move 
your mouse 

 
SeaDAS workspace: 
 

- To get more space to view your image, you can minimize any of the 
workspace windows (File Manager, World Map Location, Pixel Info, etc.) 
on the right or left. Once they are minimized, you can hover over the 
workspace windows to see. 

- If you’ve moved things around and don’t like it, you can always “View > 
Toolbars > Reset Toolbars”  

- If you are ever unsure what a button does in SeaDAS, hover over it with 
your mouse for a tooltip! 

 
SeaDAS display basics: 
 

4. In order to zoom and navigate around the image, you can  
a. Click the magnifying box on the top tool bar and draw a box around 

the area you want to zoom to 



 
b. and click/drag to move location with the hand icon 

 
c. Or, use the “Navigation” panel on the left 

 
 

i. The 4th icon down  is a quick way to zoom out to the 
whole image  

ii. You can rotate the image with the arrows at the bottom right 
of the panel 

 
iii. Or you can use the scroll wheel on your mouse. 

 



5. You will be creating different layers on your image  
a. First, to visualize where there is no data (referred to in SeaDAS by 

NaN, meaning “Not a Number”), click the ‘no data layer’ icon ( ) 
in the upper tool bar 

b. Add the land or coastline by clicking the landmask icon ( ) 

 
 

1. Pick the resolution (1km or 10km). Try 10km for now 
for a global image 

2. A “Super Sampling Factor” value >1 will increase the 
resolution of the coastline, but will take much longer 
to process. Try 1 for now, but for your final projects 
you might experiment with this value 

3. You can change the color of the coastline/land/water 
masks and enable them by clicking on/off “enabled in 
all bands” for each of the masks. Add a landmask. 

4. “Create masks” will add the layers to the image (this 
can take a few minute depending on your selection) 

c. Once you’ve created new layers (including landmasks, coastlines, 
gridlines) they are all stored in the “Mask Manager” on the right side 
of your work space 



 
 

i.  You can toggle layers on/off as well as dragging to change 
the order in which they are displayed 

ii. You can also change the color (RGB or selecting on the drop 
down menu) and transparency (in fraction, 0=not 
transparent, 1=100% transparent) 

iii. Note: if mask manager does not automatically appear it can 
be found in View > Tool Windows > Mask Manager 

d. Add gridlines (aka graticule) by clicking the gridline icon  
i. To edit how the gridlines look, in the “Layer Manager” click 

“Map Gridlines,” then click the edit icon on the right 

 
ii. This will bring up the layer editor toolbox on the lower left 

side of the screen, where you can change formatting of the 
gridlines and associated labels 

 
Working with multiple files: 
 

1. Open the second file (from your personal directory) and display SST by 
double clicking the band. 

2. To visualize multiple windows at once, click Window > Tile Evenly (or 
Horizontally or Vertically, if you prefer) 

3. In order to synchronize the windows when you zoom/move, click the icon 
shown below that says “Synchronize views across multiple image 
windows” in Navigation Controls when you hover the mouse over it. 



 
a. Now, if you move one of the images around (with the hand tool) the 

other one will move as well 
4. To synchronize curser motion and the associated pixel info click the 

lowermost icon. When you hover your cursor over the icon, “Synchronizes 
Cursor Position across multiple windows” should appear. You will not be 
able to see the associated pixel information for both files at once until the 
files are collocated (see 5). 

 
5. If you want to do analysis on bands from different files (like adding or 

subtracting one band from another), you may have to create a single file 
that has bands from multiple files. To do this, you use the collocation tool 

in the top toolbar ( ) which can combine two files (including all the 
associated bands) at once 

a. In SeaDAS, these files are considered the ‘Reference’ file and the 
‘Secondary’ files, though past versions of the software have used 
different terminology, and some menus may not reflect this change 
(see here for why this terminology was historically used and efforts 
to modernize this language in coding). The projection of the 

https://en.wikipedia.org/wiki/Master/slave_(technology)


reference will be conserved in the new file. 
b. Select the Reference file 

i. Note: it does not matter which file you select as the 
Reference and which is the Secondary 

c. Select the Secondary file (click the + symbol, and select ‘Add 
product(s)’ to select the other file that is loaded in the File Manager 
already.  If the file was not opened already select “Add product 
file(s)”  

d. Name the new file, and change the target directory to the folder you 
created earlier 

e. Change suffixes to match the reference and secondary. For 
example below, I have the reference file set as file ‘20150701’, so I 
will identify the bands from this original file by using the suffix “jul”. 

f. When you are ready, click “Run” to combine the files into a 
collocated file. 

 

 
 

g. The new file will be added to File Manager. Note that the original 
bands can now be identified by the suffix you provided 

 



 
 

6. What if you want to do some band-arithmetic? For instance, to find the 
SST difference between two months? Or the average of two or more 
scenes?  

a. Click “band-math” icon in the top toolbar ( ) 
i. The ‘target product’ will store the band you will make using 

‘band-math’. Select your collocated file. 
ii. Edit the math expression (click “Edit Expression…”). For 

example, let’s find the SST difference between summer 
(July) and winter (January) of 2015. To do so: 

1. Select the bands and arithmetic functions 
 

 
 

a. You can also do other math expressions 
including “if/then” statements etc. (check out 
the drop down options under constants, 
operators, functions) 

iii. Name the new band  
iv. Add to “description” as a reminder  

 



 
 

v. Click “Ok” 
b. Use your mouse to get a sense of the SST differences. 

i. What is the general range? What are the units? What 
general trend do you notice? Does that make sense for the 
band-arithmetic that you calculated?  

ii. Hover over the band in ‘File Manager’ to remind yourself of 
the band-math description 

 
Color scheme: 
 

1. You can pick from pre-made color bars in “Color Manager” on the left side 
of your workspace 

a. Under scheme, SeaDAS pairs typical color schemes with products. 
These are designed for typical ranges/distributions of oceanic 
parameters (like, Chl). 

b. You can also pick from a CPD (Color Palette Definition) file directly 
c. Try applying different color schemes to both the temperature 

difference band as well as original SST bands.  Make sure to enter 
the correct range. 

i. How does that change the way your data look? Choosing an 
appropriate color scheme is very important for how you 
report data! 

ii. A helpful trick for setting the range – Within the Color 
Manager “Basic” view, click “From Data” or under “Sliders” 
you can see the minimum and maximum of your data range  

 

2. You can add a color bar by clicking the color bar icon at the top ( ) 
a. Within Layer Manager > Color Bar Legend, you can edit (ex. Title, 

Units) in the Layer Editor (tab next to Color Manager on the left 



side).  
i. Mac Tip: if you want to make the degree symbol °, hold shift-

option-8! 
ii. Windows Tip: turn on numLock then hold alt and type ‘0176’ 

on the number pad. The degrees symbol should appear 
 

 
 

iii. You can either choose SeaDAS to automatically space the 
numbers on the bar OR you can manually choose what 
numbers are displayed (in the above example the minimum 
and maximum should be the same so that no difference 
(zero) is white, whole numbers will look better too, so you 
can change to -15,-10,-5,0,5,10,15) 

iv. If your color bar looks weird, make sure that the log scale is 
turned off (in the “Color Manager” panel, make sure that the 
log10 button in the top right is not depressed, it’s grey if it’s 
turned on. You should also re-set the range of the colorbar 
to center on 0, with negative and positive values as the 
range limits.  

v. SeaDAS will automatically make the color bar horizontal, but 
if you prefer you can select a vertical orientation  

vi. If you want to change the size, open the color bar settings 
again and you can edit the legend scaling (Layer Editor – 
ColorBar > Size & Scaling section) bigger or smaller  

1. If some of your gridlines overlap with your colorbar, 
you can turn off those labels. In this example, you 
would turn off the South Labels in the Gridline Edit 
menu (Layer Manager -> Graticule -> Edit icon) or 
you can remove the colorbar title. 



 
 

 
 
Contour Lines: 

1. To add contour lines to your data, click  
a. Select the start and end value to your contour interval as well as 

the number of intervals 
b. Select log if you want a log distribution of intervals 
c. Preview/edit allows you to edit the contour value/color 
d. You can add another ‘set’ of contour intervals by clicking the + 

 
Subset: 
 

1. If you want to only view part of your region, you can subset the image 
a. First resize the window (by zooming and moving) to roughly what 

you’d want your cropped image to look like. 
i. For example, if I wanted to look at the North Atlantic 

  



b. Click the subset tool ( ) which will default to the boundaries you 
set by zooming in 

i. You can either accept these coordinates or edit them 

 
c. This creates a new file in File Manager 

 
Saving: 
 

1. Save an image 
a. Right click on the image and click “Export View as Image”. To right-

click on a mac, press control-click. Alternately, go to the top menu 
and click on File > Export > Other > View as Image  

i. Select your personal directory 
ii. To import only the image of the data (within the boundaries) 

in the original resolution of the raster data, select “View 
region” in the image region section and “Full resolution” in 
the image resolution section. 

 
iii. But if you want to include anything outside the image, like 

the color-bar and gridline labels, select “Full scene”  



 
1. However, when you select view region, SeaDAS 

might reduce the image size. If you want to have a 
higher resolution, change one of the dimensions 
image size to match the source data size (the other 
dimension will scale in proportion) 

2. Save the color bar as a separate file 
a. Right-click on the image and click “Export Color Bar Legend” 

3. Save a data file: 
a. In File Manager, right click on File > Save Product As. 

4. You can save your SeaDAS session (which saves what bands and 
windows you have open) 

a. File > Session > Save Session (As) 
i. Now, you can open this session when you resume work and 

SeaDAS will remember the windows open, the masks/layers 
on/off, which files are open etc. It will restore SeaDAS 
exactly as you see it.’  



5. Quit SeaDAS  
 
 
 
TO GET CREDIT FOR LAB 1: 
Please send Kevin (arrigo@stanford.edu) the image you just exported! 
 
Please send the “full scene” and make sure your colorbar is shown. Name your 
file as follows: 
{yourFirstName}_{yourLastName}_lab1.png 
 
 
Lastly, in preparation for Lab 2: 
 

1. Register with EARTH DATA here: https://urs.earthdata.nasa.gov/home 
and make sure you save your login info for yourself somewhere.  Don’t put 
special characters (like /&*) in your password, since it might mess up the 
next step. 

2. Create a .netrc using your Earthdata login credentials from the Terminal 
(NOTE: this step will not work on Windows. If you are on a windows 
computer, skip this step): 

 
 

echo "machine urs.earthdata.nasa.gov login USERNAME 

password PASSWD" > ~/.netrc 

 

chmod 0600 ~/.netrc 

 

(press enter after each of these lines) 
Replace USERNAME and PASSWD with your Earthdata username and 
password. 

 

 
 
 
  

https://urs.earthdata.nasa.gov/home

